Print Page | Close Window

Can't add categories/Packages

Printed From: Almyta Systems
Category: Almyta Control System (ACS) and ABC Inventory
Forum Name: Installation, Updates, Technical Issues
Forum Discription: Dedicated to any technical issues of the application.
URL: http://www.almyta.com/forum/forum_posts.asp?TID=8088
Printed Date: 16 Oct 2019 at 3:11pm
Software Version: Web Wiz Forums 10 - http://www.webwizforums.com


Topic: Can't add categories/Packages
Posted By: pivic
Subject: Can't add categories/Packages
Date Posted: 17 May 2015 at 6:29am
Hello,

I can't add successfully any categories...

I go to Inventory -> Warehouse Locations -> Categories. 

Press on add new, enter in the field "Labour", tick the service Box. The ID is automatically set to 0 
Then it gives me the error: "The changes you requested to the table were not successful because theywould create duplicate values in the index, primary key, or relationship. Change the data in the field or fields that contain duplicate data, remove the index, or redefine the index to permit duplicate entries and try again. "

The only two other Categories I have in this list are: ID 1  General, ID 2 Supplies.


The same problem occurs if I try to add a Package...

What am I doing wrong? 

Thanks,
Pivic



Replies:
Posted By: Debra
Date Posted: 18 May 2015 at 6:52am

Could you please go to System/Error Log/Shared Components, select all text, copy, and paste into this forum.  

The last line could contain your windows login, just remove it.



Posted By: pivic
Date Posted: 21 May 2015 at 10:15am
Hello Debra,
WinNT 6.1
Logged in Access as: Admin
OLE/DDE Timeout is 30 seconds
DDE Requests are not ignored
Default Record Locking is: No Locks
Default Open Mode for Application is: Shared
Default Directory is: xxxxx\Documents\
Open file: C:\AlmytaSystems\#Company ltd#\acs312.logic
MS Access version: 15.0.4701.1001; RunTime
Database Engine version: 15.0.4699.1000
MS Access folder: C:\Program Files (x86)\Microsoft Office\Office15\
NAME: VBA v. 4.2, C:\PROGRA~2\COMMON~1\MICROS~1\VBA\VBA7.1\VBE7.DLL
NAME: Access v. 9.0, C:\Program Files (x86)\Microsoft Office\Office15\MSACC.OLB
Broken references: C:\Program Files (x86)\Common Files\Microsoft Shared\OFFICE12\MSO.DLL
NAME: DAO v. 12.0, C:\Program Files (x86)\Common Files\Microsoft Shared\OFFICE15\ACEDAO.DLL
NAME: stdole v. 2.0, C:\Windows\SysWOW64\stdole2.tlb
NAME: MSComctlLib v. 2.0, C:\Windows\SysWOW64\MSCOMCTL.OCX
SYSTEM DB: xxxxx\Roaming\Microsoft\Access\System1.mdw
I found a way around it... I copied the #Company ltd# folder to a computer with Office 2010 and adding a new category would work fine. It would increase the ID instead of creating an ID 0. 

If I then copy the #Company ltd# folder back to my computer with office 2013, I still can't add categories... It would still add a new one with ID 0 which creates the error. 




Posted By: Debra
Date Posted: 22 May 2015 at 4:58am
 You have a broken reference to C:\Program Files (x86)\Common Files\Microsoft Shared\OFFICE12\MSO.DLL file. Try to uninstall MS Access 2007 runtime from the Windows\Control Panel\Programs and then install our application again. Anyway, file MSO.DLL is missing. Also you can, open a screen like Categories, go to System/Unhide Fields menu. Now you can manually enter new ID. At the same time, it is hard to say what else does not work. ABC Inventory was last compiled before Access 2013 appeared on the market. We ran tests and did changes to the commercial app ACS, but did not do anything with ABC Inventory. We are planning to update it this year. 


Posted By: pivic
Date Posted: 22 May 2015 at 7:19am
Thank you Debra! 
I uninstalled and reinstalled the software and now it works fine ! Shame on me for not having tried this before.... 

Thanks!



Print Page | Close Window

Forum Software by Web Wiz Forums® version 10 - http://www.webwizforums.com
Copyright ©2001-2011 Web Wiz Ltd. - http://www.webwiz.co.uk